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tNavigator installation:

Setup software (an installer) for the Linux version of tNavigator 

has been added. The installer runs in the console and is 

implemented as a sequence of ASCII graphic screens.

The program also installs the user documentation.

Log panel:

A common view of the log panel with an option to 

search and filter messages by tags or mask is now 

supported for Simulator, Geology Designer, Model 

Designer, Network Designer, and PVT Designer.

Key new features in 21.4
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The calculation of polymer options on GPU is now 

supported.

For black oil models, the option of multicomponent 

water is now supported.

Labyrinth inflow control devices for multisegment 

wells are now supported.

In the Simulator kernel:

Key new features in 21.4

GASWAT

• PMIXLIN

• PMIXNLIN

• PMIXTAB

• PMIXVTAB

• PLYELVSVCS

• PLYSHEARA

• PLYELVSVA

• PLYELVMAXA
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For isothermal compositional models in E3 format, the option 

of modeling a two-phase gas-water system using an equation 

of state is now supported (the GASWAT keyword).

For geomechanical modeling, the linear isotropic plasticity 

model is now supported. The tensor of plastic deformations 

for such a model can be implemented as a function of the 

parameters of the dynamic model.

In the Simulator kernel:

Key new features in 21.4
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In the tNavigator graphical interface:

Oil production graphs for various recovery 

mechanisms are now available in black oil 

models (oil produced due to rock 

compaction, due to water influx, etc.)

Key new features in 21.4
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In the Assisted History Matching and Uncertainty module:

A new mode to create a neural network for 

a large number of parameters has been 

implemented. In that case, a single neural 

network is built, which helps reduce the 

training time.

Key new features in 21.4
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In Geology and Model Designers:

It is now possible to create Page Layout with several 

pages. This option allows the visualization of objects 

that do not fit on one page. 2D-Maps of any size can 

be printed using a simple A4 printer.

The Preview option is now available to control the 

data exchanging process in the Project Data 

Exchanger.

Key new features in 21.4
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In Geology Designer:

It is now possible to set a custom name for each imported 

well log. A dictionary of log names (mnemonics) can be 

predefined and applied to all imported logs.

An interactive tool for quality control of fault creation has 

been added: Fault QC.

Key new features in 21.4
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In Geology Designer:

New tools are available to model Discrete Fracture Networks 

(DFN). New settings are available to control fracture orientation 

within the modeling area. In the list of available windows and 

tabs, a new object has been introduced: Stereonet/Directional 

Rose.

An option for azimuthal images visualization and interpretation 

during well navigation is now available. An option to generate 

synthetic images for the drilled well based on the reference well 

data has been added.

Key new features in 21.4
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In Geology Designer:

New tools are available to work with geobodies and 

triangulated surfaces:

• automatic creation of geobodies based on point sets or 

fence polygons,

• interactive editing of geobodies’ triangulated surfaces in 3D,

• properties creation by geobodies,

• import/export of triangulated surfaces and geobodies in 

.tsurf, .ply, .dxf formats.

Key new features in 21.4
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In Model Designer:

The following fluid properties associated with the analytical 

model of polymer injection are now supported:

• the elongational viscosity multiplier as a function of the polymer 

concentration in a table,

• the elongational viscosity multiplier as a function of the stream 

velocity,

• the temperature-dependent polymer half-life period,

• etc.

Key new features in 21.4

• PLYELVSC

• PLYELVSV

• PLYELVMAXA

• PLYELVSVA

• PLYDHFLF

• PLYSHEARA

• PLYKRRF

• PLYSHLOG
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In Model Designer:

In Fracture Simulator, it is now possible to take into 

account the mutual influence of fractures 

implemented at different wells to model the fracture 

stage at the current well.

In RP Designer, a new tab titled “SRP” (scaled relative 

permeabilities) has been added to calculate the 

hysteresis effect and RP curves in the presence of 

surfactants.

It is now possible to visualize RP curves by changing 

endpoints.

Key new features in 21.4
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In Well Designer:

A new object—Sucker Rod Pump—has been added.

In Network Designer:

It is now possible to import and export data for network 

objects in tabular form in a user-specified format.

In PVT Designer:

In the workflow, compositional and black oil variants 

can now be matched to samples.

Key new features in 21.4
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Cross-module changes

Many changes involved in tNavigator modules integration influence multiple 

modules, but are only mentioned once in this presentation. These include:

A common view of the log panel;

Highlighting of calculations with variables in workflows;

New grid properties in Model Designer and Simulator;

…etc.

For the full list of changes to each particular module, please read the 

Release Notes.

This presentation contains only the main changes to every module. The 

complete list of changes, together with the new keywords and options, are 

likewise available in the Release Notes.
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tNavigator Kernel
Simulator kernel 21.4
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Simulator kernel 21.4

GPU calculations

The following calculations are supported on GPU:

Baker’s model for relative phase permeabilities of gas and water (BAKER1, BAKER2).

The calculation of rock hysteresis (ROCKCOMP HYSTER/BOBERG + ROCKTABH).

The calculation of polymer options (PMIXLIN, PMIXNLIN, PMIXTAB, PMIXVTAB, PLYELVSVCS, 

PLYSHEARA, PLYELVSVA, PLYELVMAXA).

In full GPU mode (GPU_MODE 4, 5):

The calculation of aquifers for compositional models with multicomponent water.

The simultaneous chopping of pressures and saturations (RUNCTRL CHECKP 2).

The export of boundary conditions for split models.

The calculation of variables that are taken from the previous timestep in the AIM scheme. 
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Simulator kernel 21.4

Options of multicomponent water and chemical 
reactions in black oil models

For black oil models of E3 format, the option of 

multicomponent water is now supported (the COMPW 

keyword).

For black oil models of E3 format (including models with 

the option of multicomponent water), the modeling of 

chemical reactions is now supported (the REACTION

keyword).

𝐂𝐇𝟑𝐂𝐎𝐎𝐂𝟐𝐇𝟓+𝐇𝟐𝐎 → 𝐂𝐇𝟑𝐂𝐎𝐎𝐇 + 𝐂𝟐𝐇𝟓𝐎𝐇

+ → +
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Simulator kernel 21.4

GASWAT option

For isothermal compositional models of E3 format, the option of modeling a two-phase

gas-water system using an equation of state is now supported (the GASWAT keyword).
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Simulator kernel 21.4

New options for models in IN, NE formats

For models in NE format:

Polymer injection, polymer adsorption, and polymer effect on 

permeability and viscosity are now supported (the keywords are 

VISCOSITY, ADSORPTION, PERM_REDUCTION, SHEAR, 

POLYMER, EPHIP, STREAM_POLYMER).

For models in IN format:

The Python object CellSelectionFamily (a set of blocks) is now 

supported.

The Python operations in the SCHEDULE section are now 

supported.
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Simulator kernel 21.4

Permeability change in SCHEDULE

The change of permeability in the SCHEDULE section is now supported via the multipliers 

PERMMULT{X,Y,Z,XY,XZ,YZ,XYZ}.
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Симулятор 21.4

Labyrinth inflow control devices
Labyrinth inflow control devices for multisegment wells are now supported (the WSEGLABY keyword)



22

The old formula

(FRACTURE_VIRTUAL_CF_LOGIC SUM)

The new formula

(FRACTURE_VIRTUAL_CF_LOGIC NEWTRAN)

Simulator kernel 21.4

Connection factor calculation

The formula for calculation of connection factors for virtual perforations has changed: it now 

uses the harmonic average instead of the sum of the permeabilities on both sides of the 

fracture. The legacy logic is turned on by the FRACTURE_VIRTUAL_CF_LOGIC SUM option of 

the TNAVCTRL keyword.
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Simulator kernel 21.4

Geomechanical modeling

The linear isotropic plasticity model is now supported. The tensor of plastic deformations for such a 

model can be implemented as a function of the parameters of the dynamic model using the keywords 

GMPLSTRX, GMPLSTRY, GMPLSTRZ, GMPLSTRXY, GMPLSTRXZ, GMPLSTRYZ to define the tensor’s 

components
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Graphical Interface 21.4

Visualization of the Plastic strain tensor

Plastic strain tensor components can now be visualized in 2D and 3D (2D or 3D → Grid Properties →

Calculated → Plastic Strain Tensor)

The plastic strain tensor is dimensionless and allows taking plasticity into account in the calculation of 

geomechanics. Thus, it becomes possible to calculate more correctly the change in porosity and the parameters 

associated with it.
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Graphical Interface
Graphical Interface 21.4
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Graphical Interface 21.4

Graphs of pressure drops in network nodes 

Graphs of pressure drops in network nodes are now supported (the NETWORK option):

• the pressure drop in a production network node (GPRB);

• the pressure drop in a gas injection network node (GPRBG);

• the pressure drop in a water injection network node (GPRBW)

(Graphs → Node → Pressure → Node Pressure Drop)

GPRGB

GPRGW
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Graphical Interface, Model Designer 21.4

Displaying graphs by blocks in binary format

Graphs for blocks saved in UNRST/UNSMRY binary format can now be visualized (including the velocities 

of oil, gas and water). It is necessary to set the output to the restart files so that they contain the

corresponding property (for velocity, the VELOCITY option of the RPTRST keyword should be used) and 

the I, J, K indices of the grid blocks using the B* mnemonics in the SUMMARY section (for velocities, the 

mnemonics BVELW, BVELO, BVELG should be used) (Graphs → Graph Templates → Blocks → Parameters)
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Graphical Interface, Model Designer 21.4

Graphs for oil recovery mechanisms

Oil production graphs for various recovery mechanisms are now available in black oil models (oil 

produced due rock compaction, water influx, etc.) (Graphs → Analytics → FIPNUM → Parameters)

where:

PV is the pore volume;

So is the oil saturation;

Sg is the gas saturation;

Sw is the water saturation;

d(PV) is the change in pore volume in one timestep;

d(Sg) is the change in gas saturation in one timestep;

d(Sw) is the change in water saturation in one timestep ;

Fwt is the fraction of Sw, that is a water tracer;

Fgt is the fraction of Sg, that is a gas tracer;

Bo is the oil volume factor.

The graphs allow analysis of the 

way production is influenced by 

changes in the reservoir 

properties of the rock and the 

fluid physical properties during 

reservoir engineering.
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AHM and Uncertainty
AHM and Uncertainty 21.4
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AHM and Uncertainty 21.4

Neural Network Proxy Model

A new mode to create a neural network for a large number of parameters has been implemented 

(Create Neural Network Proxy Model from Selected Variants → the tab Proxy Models → Create Single 

Neural Network For All Object-Parameters). In that case, a single neural network is built, which helps 

reduce the training time

Поддержан новый режим построения
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AHM and Uncertainty 21.4

Setting custom variables for the 
Ensemble algorithm

Custom variables can now be added to the Ensemble algorithm. They are specified in a custom 

workflow (Workflows → Available Calculations → Property Modeling → Ensemble → Create Variables 

by Ensemble → Add Custom Variables With Respective Workflow)
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AHM and Uncertainty 21.4

Building a Probability Model 

A probability model can now be built (the Build Probability Model button) in the Analysis tab on the 

basis of calculation results of some experiments if they are run in the same variable space. The 

variants and the objective function that will be used for building the probability model should be ticked 

in the Objective Functions and Results tree
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AHM and Uncertainty 21.4

O.F. Standard
A new type of objective function, Standard, has been added to help cut outliers on timesteps

𝑶𝑭𝑮𝑳𝑶𝑩 =

𝒊=𝟏



𝒒=𝟏

𝒘𝒊𝒘𝒒

σ𝒕=𝟏
𝒏 𝒘𝒌

𝑺𝒒,𝒊,𝒌 − 𝑶𝒒,𝒊,𝒌
𝝈𝒒,𝒊,𝒌

𝟐

σ𝒕=𝟏
𝒏 𝒘𝒌

OFGLOB is the global O.F .
S is the calculated value, 

O is the historical value of the component,

q is the identifier i at the timestep k, 

σ is the measurement error, 

w is the weight coefficient,

n is the step number
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Geology Designer and Model Designer
Geology Designer and Model Designer 21.4
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Geology Designer and Model Designer 21.4

Manually assign a trajectory to a well

It is now possible to manually assign the trajectory being imported to a well. If some wells have already 

been imported into the project, the user is able to choose one of the options: delete all the trajectories 

and import them again; update all trajectories; import the trajectory as one of the possible versions of 

the well trajectory (Import→ Well Trajectories → User Defined Well Search)



36

Multiple Grids in the 2D visualization tab

Multiple grids visualization in the 2D tab is now supported (2D tab → Settings → General→ Allow 

Multiple Grids)

Geology Designer and Model Designer 21.4
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Controlling the position of visualization tabs

It is now possible to enforce a uniform size upon the visualization tabs using the CTRL key

Geology Designer and Model Designer 21.4

+ CTRL
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Geology Designer and Model Designer 21.4

General: Workspaces

An option to save tab combinations in a project has been added: display all the necessary tabs in the 

project → View → Workspaces... → New State → Enter the name → Apply State

1

2

5

4

6

3
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If an object has been updated, it is 

highlighted with the icon

An object is highlighted via the            

icon if it has been added

Geology Designer and Model Designer 21.4

Preview of data exchanging results 

After the objects for exchange have been selected, the user may activate the Preview option, which 

highlights the objects in the current project list of objects (Project → Project Data Exchanger →

Preview)

In the list of current project 

objects, the updated objects are 

displayed as two names in preview 

mode:
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Geology Designer and Model Designer 21.4

Highlighting of workflow items with variables

Calculations containing local variables can now be highlighted in the workflow. The highlighting is 

implemented via the          icon which symbolizes the variable (Calculations and Workflows → Show 

variables tooltip)
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Geology Designer and Model Designer 21.4

Well Filters creation via Workflow

It is now possible to manage Well Filters in the workflow via Python functions. New functions allow 

creating and editing well filters (Custom Code → Well Filters → get_all_well_filters(), 

create_well_filter() etc.)
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Geology Designer and Model Designer 21.4

Page Layout: add a screenshot via Workflow

An option to add the screenshot of the current tab into the Page layout window via a workflow has been 

added: Calculations and Workflows → GUI → Create → Add Screen to Print
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Geology Designer and Model Designer 21.4

Page Layout: Page, Circle, Rectangle

It is now possible to create Page Layout with several pages: Page Layout → Pages Operations → Add 

Page

It is now possible to draw circles and rectangles in the Page Layout window. These options can be used to 

highlight important information: Page Layout → Add Circle/Add Rectangle
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Geology Designer and Model Designer 21.4

Page Layout: Multi-page print

An advantage of this feature is that maps of any format can be printed using a simple A4 printer:

Page Layout → Pages Operations → Use Solid Page → Settings → Solid Page Area



Updated Log Panel

Contents

The following options are now supported:

• A common view of the log panel with an option to 

search and filter messages by tags or mask is 

now supported for all tNavigator modules: 

Simulator, Geology Designer, Model Designer, 

Network Designer, PVT Designer, etc.

• Message prefixes visualization (step, day, date, 

time);

• Displaying information about dates and well

names in error messages;

• Clearing the log panel from all messages;

• Changing message colors;

• Output of log messages from several modules at 

the same time. 
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Common view of the log panel for tNavigator modules

A common view of the log panel with an option to search and filter messages by tags or mask is now 

supported for all tNavigator modules: Simulator, Geology Designer, Model Designer, Network Designer, 

PVT Designer, etc.

All tNavigator modules 21.4
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Message prefixes visualization in the log panel

Blocks for message prefixes (step, day, date, time) are now visualized. The format settings of message 

prefixes can be changed using the REPORTFILE and REPORTSCREEN keywords

(Log panel → Right-click → Show Timestamps/Show timesteps)

Graphical Interface, Geology Designer, Model Designer, Network Designer, PVT Designer 21.4
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Graphical Interface, Model Designer 21.4

Error messages detailing

Information about dates and well names is now visualized in error messages for the keywords of the 

SCHEDULE section
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Change the color of messages and clear the log panel

All messages can now be cleaned off of the log panel (Log panel → Right-click → Clear All)

The colors of messages (warnings, errors, etc.) in the log panel can now be edited

(Log panel → Right-click → Color Settings)

Graphical Interface, Geology Designer, Model Designer, Network Designer, PVT Designer 21.4
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Geology Designer and Model Designer 21.4

Log messages from several modules simultaneously

It is now possible to output log messages from several modules simultaneously. The user can now 

select modules whose logs will be displayed in the log panel: Geology Designer, Model Designer, PVT 

Designer, Well Designer or Network Designer. This option is applicable to work with integrated models 

in Project Manager (Project Window → Log Management)
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Geology Designer
Geology Designer 21.4
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Geology Designer 21.4

Restrict Mode for seismic horizons and faults

Restrict Mode has been added for visualization of seismic horizons and faults only at the intersections 

with the seismic data displayed in the 3D tab (3D tab→ Settings → Seismic Fault and Horizon →

Restrict Mode)
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Color management of 2D and 3D surveys in the 2D tab

2D and 3D seismic surveys can now be simultaneously displayed in the 2D window in different colors 

(2D tab → Settings → Seismic 2D/3D→ Color)

Geology Designer 21.4
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Geology Designer 21.4

Hotkeys for seismic data interpretation

Hotkeys to work with seismic data have been added

The following hotkeys can be used in the 3D tab:

• [M] enables the Move Seismic Slice option

• [I] opens the Interpret Seismic Surfaces menu

• [1-6] activates the corresponding tool of the menu
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Geology Designer 21.4

Hotkeys for seismic data interpretation

Hotkeys to work with seismic data have been added

The combination of the left/right arrow keys with Ctrl allows moving Inlines, Crosslines and Slices by a 

specified step in the Seismic tab, as well as in the 3D window for the direction selected in the Settings

window
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Geology Designer 21.4

Markers creation by seismic horizon

A calculation to create markers at the intersection of well trajectories with seismic horizons has been 

added (Markers → Calculations→ Build Marker by Seismic Horizon)
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Well symbols control for markers in the 2D tab
Geology Designer 21.4

Symbol codes are set for 

markers of different horizons 

using the numeric marker 

attributes

Well symbols can be set for markers using the numeric marker attributes, for example unique well 

symbols for different horizons in the 2D tab
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Geology Designer 21.4

Interactive eraser for well logs

Manually delete a part of a well log curve in the Well Section tab 

Delete points or fill them with an undefined value 

Well Section → Right toolbar → Edit Well Logs → Erase Points

The selected 
interval

Erase 
points

Fill with an 
undefined 

value
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Geology Designer 21.4

Well logs mnemonics during their import
Set a custom name for each imported well log, different from the name indicated in the file. 

May be useful when you routinely need to rename loaded well logs (e.g., Gamma Ray to GR, GAMM or 

GK) (Logs → Calculations → Import → Use Global Log Mnemonics)
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Geology Designer 21.4

Well logs mnemonics during their import

A dictionary of log names (mnemonics) can be predefined and applied to all imported logs

(Settings → Well Log Mnemonics)

Set custom names or use the existing 
mnemonic dictionary 
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Geology Designer 21.4

Water saturation logs based on the Simandoux 
equationWater saturation logs based on the Simandoux equation

(Logs → Calculations → Water Saturation Simandoux)

SWSimandoux=
𝒂.𝑹𝒘

𝟐.𝚽𝒎 ∗ (
𝑽𝒔𝒉

𝑹𝒔𝒉

2
+

𝟒𝝓𝒎

𝒂.𝑹𝒘.𝑹𝒕
−

𝑽𝒔𝒉

𝑹𝒔𝒉
)

a: a constant based on lithology

m: a constant based on lithology

phi: the DPHI log is used

Vsh: the shale volume log is used

Rt: the formation resistivity 

Rw: the formation water resistivity (a constant obtained 

via local well measurement)

Rsh: the resistivity of shale in the formation (taken from 

the formation resistivity at the highest Vsh value in each 

well)
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Geology Designer 21.4

Color filling by a Stratigraphic table

Visualization of color filling between markers for all wells in the well section tab is now available. To 

display the color filling, a Stratigraphic Table with the required markers must be created beforehand 

Stratigraphic Table → Create → Edit Stratigraphic Table → the Well Section tab → check the created 

table in the object tree.
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Geology Designer 21.4

Color filling by a Stratigraphic table

Visualization of color filling between markers for all wells in the well section tab is now available. To 

display the color filling, a Stratigraphic Table with the required markers must be created beforehand 

Stratigraphic Table → Create → Edit Stratigraphic Table → the Well Section tab → check the created 

table in the object tree.
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Point Set filtering
Geology Designer 21.4

X value specified

A calculation titled Cut Point Set by Attribute and Coordinates has been added. It allows filtering points 

by coordinates and/or by numeric attributes (Point Sets → Calculations→ Transformations→ Cut 

Point Set by Attribute and Coordinates)

Depth specified as a 

numeric attribute
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Flip 2D-Maps and Horizons calculation

For Horizons and 2D-Maps, a new calculation has been added: Flip. Horizons and 2D-Maps can be 

flipped along the I and/or J directions (Horizons/2D-Maps → Calculations→ Transformations→ Flip)

Geology Designer 21.4
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Geology Designer 21.4

Fault QC: an interactive tool

An interactive tool for quality control of fault creation has 

been added: Fault QC. It offers an interactive window, which 

shows the faults displayed in the visualization window at the 

moment and having possible errors in geometry

(the 3D tab→ Right toolbar)
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Geology Designer 21.4

Fault QC: an interactive tool

Depending on the indicated problem, the user is prompted to open the interactive faults editing tool or 

the truncation rules table. After verification, the Verified mark is set

1

2
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Geology Designer 21.4

DFN: Create DFN new options

The Create DFN calculation has been significantly redesigned. The user can now fully control the 

fractures that influence the distribution and concentration of fractures within the horizon: Geometry 

Objects → DFN → Create DFN

Z
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Geology Designer 21.4

DFN: Create DFN by Faults new options

In the Create DFN by Faults calculation, additional settings of fracture position control have been added, 

namely: relative dip azimuth and relative dip azimuth deviation: Geometry Objects → DFN → Create DFN 

by Faults
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Geology Designer 21.4

DFN: Stereonet and Rose Diagram

In the list of available windows and tabs, a new object has been introduced: Stereonet/Rose Diagram. A 

Rose diagram displays objects that have an azimuth, while Stereonet describes 3D objects which are 

characterized not only by an azimuth (direction), but also by a slope.
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Controlling the priority of input data when creating 
Structural Model horizons

In the Extended Build Horizons of Structural Model calculation, an option to set the input data priority to 

control the degree of their influence on the result has been added. This allows some input data a 

greater degree of influence on the resulting horizon (Structural Models → Horizons→ Extended Build 

Horizons of Structural Model → Interpolation Priority)

Geology Designer 21.4
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Fault Extension in a Structural Model

In the calculations Add faults to the structural model and Add Multiple Input Faults to the Structural 

Model, an option titled Extend Faults to Model Box Polygon has been added.

(Structural Models → Faults→ Calculations)

Geology Designer 21.4

Allows extending the fault laterally by a 

specified distance or to the vertical 

boundaries of the structural model box
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Coordination of a structural faults intersection
In the calculations Create Grid by Point Sets and Faults and Create Grid by Horizons and Faults, an 

option titled Intersect Structural Faults Along Sticks has been added. During the calculation, this option 

alters the intersecting structural faults so that they intersect via a common stick (3D-Grids →

Calculations→ Create Grid by Point Sets and Faults/Create Grid by Horizons and Faults → Advanced 

Settings)

Geology Designer 21.4
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New Object: Grid Fault

A new type of object has been added: Grid Faults. It represents a surface and is necessary to understand 

how the fault is embedded in the 3D model. It allows quality control of the created fault model and visual 

comparison with the original faults (Geometry Objects → 3D-Grids → Grid Faults)

Geology Designer 21.4

Created automatically as a 

result of the calculation
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Geology Designer 21.4

Faults on Grid: Split by Property

An option to split a Faults on Grid object into segments with the help of a discrete property has been 

added. Each new segment of the initial object is the intersection of the fault surface with the grid cells 

within the limits of the appropriate discrete zone (Geometry Objects → Properties → Faults on Grid →

Split Fault on Grid by Property)
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Geology Designer 21.4

Geobody creation based on point sets or polygons

An option for automatic creation of geobodies based on point sets or fence polygons has been added 

(Calculations → Create → Create Geobody by Point Set/Fence Polygons)
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Geology Designer 21.4

Geobody surface editing

A new tool for interactive editing of geobodies' triangulated surfaces in 3D has been added (3D → Edit 

Triangulated Surface)
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Geology Designer 21.4

Create properties by geobodies

An option to create properties by geobodies has been added. In this calculation, there are two types of 

settings available for the user: either each cell of the property will reflect this cell's volume fraction 

located within the modeled geobody, or each cell located within the geobody will be assigned one 

user-defined value, and the cells outside will be assigned another value

(3D-Grids → Properties → Calculations→ Create → Create Build Property by Geobody)
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Geology Designer 21.4

Import/export of triangulated surfaces and geobodies

An option for the import/export of triangulated surfaces and geobodies in .tsurf, .ply, .dxf formats has 

been added (Geobodies/Triangulated surfaces → Calculations→ Import/Export)
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Geology Designer 21.4

Contacts filtering based on discrete properties

An option for contacts filtering based on discrete properties (Zones/Regions) has been added, which 

allows visualization of the contact for every single layer or deposit (Settings → Contacts→ Discrete 

Property Filter)
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Geology Designer 21.4

Point set and polygon creation on a Cross-Section

Tools for point set and polygon creation and editing have been implemented for the Cross-Section tab. 

These tools are important for raster cross-sections digitizing, seismic data, manual corrections during 

conceptual modeling or geological cross-section design (Cross-Sections→ Edit Point Sets/Edit 

curves)
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Contact visualization in the 2D tab

In the 2D visualization tab, you can now display contacts as contours. The option helps to prepare 

reporting materials (the 2D Tab)

Geology Designer 21.4

The outer and inner 

contours are displayed
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Geology Designer 21.4

Facies Probability in Data Analysis

A new tab titled Facies Probability is now available in Data Analysis, allowing analysis and, if 

necessary, editing of the dependence between a discrete property (facies) and a continuous one (for 

instance, a seismic attribute)



Geosteering

Contents

The following options have been added:

• Azimuthal images interpretation during well 

navigation.

• Automatic calculation of the gap between the 

drilling bit and the receiver where no 

geophysical data are present (no logs values).

• Setting a custom location for well names in the 

Cross-Section panel in the Geosteering tab

• Generation of synthetic images for the drilled 

well based on the reference well data.
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Geology Designer 21.4

Geosteering: Images interpretation
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Geology Designer 21.4

Geosteering: Images interpretation

An option for azimuthal images interpretation during well navigation has been added (Geosteering →

display the required image → Right Toolbar → click the Add Image Interpretation button)
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Geology Designer 21.4

Geosteering: Synthetic images creation

An option to generate synthetic images for the drilled well based on the reference well data has been 

added (Settings → Synthetic Borehole Image → Enable Synthetic Borehole Image → Well Log for 

Synthetic Image)
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Geology Designer 21.4

Geosteering: Offset intervals calculation

An option for automatic calculation of the distance between the drilling bit and the receiver has been 

added (Geosteering → Right Toolbar → Open Tables → LWD Offsets)



89

Model Designer
Model Designer 21.4
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Model Designer 21.4

Change the path to loaded calculation results

It is now possible to change the path to loaded calculation results. It allows using calculation results of 

other users (including for restarts) after copying the project to another folder (Cases → DynamicModel 

name → RMB on the result → Replace Path to Existing Result)

Open Cancel

Name

.
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Model Designer 21.4

Optimizing the output size of several models with the 
same grids during initialization

The grid properties and data of models can now be uploaded to a specified folder (in this case, the 

properties without changes will not be uploaded) (Settings → Result Settings → Dump Grid and 

Properties to Common Folder)
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Model Designer 21.4

Optimizing the output size of several models with the 
same grids during export

It is now possible to optimize the size of the output of included files for different cases of simulation 

models that have one base model (Cases → RMB on DynamicModel name → Export Model → Export 

Only Changed Grid and Properties to Separate Files)
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Model Designer 21.4

Polymer injection
The following fluid properties associated with the analytical model of polymer injection are now supported 

(Fluid Properties → EOR; Cases → Static)

• PLYELVSC is for the elongational viscosity multiplier 

as a function of the polymer concentration in a table

• PLYELVSV is for the elongational viscosity multiplier 

as a function of the stream velocity

• PLYELVMAXA, PLYELVSVA are for the elongational 

viscosity multiplier in analytical form

• PLYDHFLF is for the temperature-dependent 

polymer half-life period

• PLYSHEARA is for the shear viscosity multiplier

• PLYKRRF: rock permeability for the purposes of 

polymer calculation is now supported

• PLYSHLOG is for the logarithmic law of the 

dependence of the viscosity multiplier on the flow 

velocity
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Model Designer 21.4

Correlations for polymer properties
It is now possible to set polymer half-life period (PLYDHFLF) versus temperature as a correlation 

(Fluid Properties → EOR)

• PLYDHFLF is for the 

temperature-dependent 

polymer half-life period

PLYDHFLF type



95

Model Designer 21.4

Logs in RFT binary format

Import of Logs in RFT binary format is now supported (Geometry Objects → Logs → Import → From 

RFT Format (binary))
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Model Designer 21.4

BlockedWells calculator

It is now possible to work with dynamic model data using arithmetic operations in the BlockedWells 

calculator (Geometry Objects → BlockedWells → Calculations → Calculator)
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Load graphs with arbitrary dates

It is now possible to load graphs with arbitrary dates (which may differ from those set in the model)

(Graphs → Graphs Templates → Load Graphs)

Model Designer 21.4
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Model Designer 21.4

The rule Temperature of Injected Fluid

A rule to set the temperature of injected fluid is now supported (corresponds to the WTEMP keyword)

(Strategies → Thermal Properties → Temperature of Injected Fluid)



Fracture Simulator

Contents

• It is now possible to take into account the mutual 

influence of fractures implemented at different 

wells to model the fracture stage at the current 

well

• Automatic use of calculated properties in the 

simulation model for the calculation of fracturing 

stages is now supported
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It is now possible to take into account the mutual influence of fractures implemented at different wells 

to model the fracture stage at the current well. To do this, in Fracture Simulator Settings the user 

should specify the calculated fracturing stages that will be taken into account, as well as the start of 

the injection

Model Designer 21.4

Stress Shadowing between Wells
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Automatic use of calculated properties in the simulation model for the calculation of fracturing stages

is now supported. Grid properties for the stage will be automatically set from the dynamic model 

calculated for the reporting date which is closest to the stage creation date

Model Designer 21.4

Use Calculated Props from the Dynamic Model
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Model Designer 21.4

Import Fault data from an external file

It is now possible to import fault data from a model or an external file. In this case, the fault data must 

be specified using the FAULTS keyword (3D-Grids → Faults on Grid → Import Fault Grid from a Model)
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Model Designer, Graphical Interface  21.4

Automatic graph template loading

It is now possible to load graph templates automatically for new projects.

It allows use of pre-prepared graph templates to analyze field development parameters

(Settings → Options → General → Use Graph Templates for New Project/Models)



RP Designer

Contents

• The SRP tab has been added (scaled relative 

permeabilities)

• The hysteresis effect can now be calculated 

• RP curves can now be visually edited by 

changing endpoints

• Multiple graphs’ colors can be edited at once
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Model Designer 21.4

RP Designer: SRP tab (scaled relative permeabilities)

The SRP tab provides the following possibilities:

• to visualize RP curves while changing endpoints;

• to calculate the effect of hysteresis; 

• to calculate RP curves in the presence of surfactants
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Model Designer 21.4

RP Designer: change RP endpoints

It is now possible to visualize RP curves while changing endpoints (Variants → SRP → Settings →

Scaling/Hysteresis/Surfactant)
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Model Designer 21.4

RP Designer: the Hysteresis option

The new SRP tab allows the calculation of the hysteresis effect. It is now possible to select a variant for 

the main curve (drainage), the imbibition curve (Variants → SRP → Hysteresis)
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Model Designer 21.4

RP Designer: the Surfactant option

The new SRP tab allows the calculation of RP curves in the presence of surfactants. It is now possible 

to select a variant for the RP curve in the presence of surfactants (Variants → SRP → Surfactant)
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Simulator, Model Designer 21.4

Data input/output

New grid properties are available

(Cases → Properties → Writing of Results →

Additional Properties):

Mass densities of water, oil, and gas in a black oil model 

(MASSDENO/W/G)

Oil-in-place mass (OIPM), mobile oil-in-place (MOIP), mobile 

oil-in-place mass (MOIPM)

Molar densities of components (MLSC, MWAT)

K-values (KVALUES)

Number of convergence problems in each block (CPN)

... etc.
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PVT Designer
PVT Designer 21.4
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PVT Designer 21.4

PVT: extrapolating a saturated branch

When creating a black oil variant based on a compositional one, a saturated branch can be 

extrapolated above the specified saturation pressure in the case of gas injection into the reservoir

Extrapolates up to the maximum 

possible Psat in the set range

Extrapolates up to the specified Psat
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The columns correspond to the following keywords:

WNAMES, WI, MWW/MWWS, PREFW/PREFWS, 

CREFW/CREFWS, DREFW/DREFWS 

PVT Designer 21.4

Compositional: multiple water components

Multiple water components and their properties can now be set in compositional variants
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PVT Designer 21.4

Workflow: matching to samples

Compositional and black oil variants can now be matched to samples
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Network Designer
Network Designer 21.4
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Network Designer 21.4

Export objects in a custom format  

It is now possible to export data for network objects in tabular form in a user-specified format (the top 

menu Edit→ Export→ Import/Export Objects in Custom Format)

1

2
3
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Network Designer 21.4

Import objects in a custom format  

It is now possible to import data for network objects in tabular form in a user-specified format (the top 

menu Edit→ Import→ Import Objects in Custom Format)

1

2

3
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Network Designer 21.4

View the parameters of imported objects 

In the Tables tab, it is now possible to see the parameters of the network objects and the network 

topology imported from a file in tabular form.
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Network Designer 21.4

Well control by Network Designer

For integrated models, Network Designer has top priority in terms of controlling a well

(Settings → Parameters→ Properties→ Control Integrated Wells By Network Designer)

1

2

3

Well control is specified by Simulator
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Network Designer 21.4

Well control by Network Designer

Network Designer has top priority in terms of controlling a well

Activation of a well is equivalent to specification of the WCONPROD keyword along with THP control

1

2
3

Well control is specified by Simulator

4
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For Standalone and integrated models, the temperature profile in a well is taken into account in 

calculations (Settings → Parameters→ Solver Settings → Use Temperature Equations)

Network Designer 21.4

Temperature profile in a well 
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Network Designer 21.4

Import PS project

The top menu Project→ Import→ Import PS Project

The network topology will be imported to the Scheme tab along with the object parameters coinciding 

with the parameters in Network Designer, and the fluid model used in the PS project will be detected

1

2

3
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Network Designer 21.4

Separator

It is now possible to specify phases' fractions directed into the separation object(s)

(RMB on the object → Edit→ Data Type→ Advanced
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Network Designer 21.4

Bottleneck analysis

It is now possible to analyze a pipe capacity compared to its current state. If the rate through a pipe at 

the current conditions is close to its capacity limit, a warning appears in the project log in the Log 

panel (Settings → Parameters→ Properties→ Enable Testing)
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Network Designer 21.4

Pipe visualization variants in the Scheme tab

The possible options include a standard icon, an icon visualizing hydrates formation in a pipe and an 

icon with the VFP symbol, which indicates that a VFP project is in place for the pipe
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Network Designer 21.4

Coupling several Standalone models 

Each network should be active and have the same data steps. The coupling is carried out via Sources 

and Sinks (RMB on the object → Edit→ Data Type → Dependent Object and in the Dependent Object 

field specify the name of an object in the coupled project of the surface network)
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Network Designer 21.4

Rotation of network objects in the Scheme tab

The button in the right panel→ Alignment of Selected Objects → Rotate 90 Degrees Clock-wise and  

Rotate 90 Degrees Counterclock-wise
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In the Map tab, it is now possible to synchronize the Z coordinates of network objects with the surface 

map (the right-panel button 3D Coordinates Editor → Synchronize Z Coordinates With Horizon Only 

Visible Objects)

Network Designer 21.4

Synchronization of the Z coordinates with the map
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Well Designer
Well Designer 21.4
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Well Designer 21.4

Sucker Rod Pump

A new object—Sucker Rod Pump—has been added
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Well Designer 21.4

Multiediting

In the Well Construction tab, it is possible to multiedit parameter values of well construction elements

The depth may now be visualized both in measured depth (MD) and in true vertical depth (TVD)
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Well Designer 21.4

Well construction errors

The well project log in the Log panel can now be used to control errors occurring when creating a well 

construction
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Well Designer 21.4

IPR curves

It is now possible to visualize several selected IPR curves in the IPR tab
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Well Designer 21.4

Heat losses along a wellbore

The environment temperature (the TEMPERATURE parameter of the WELLDATA keyword) and the 

coefficient for the heat exchange between the wellbore and the environment (the CONDTUBE

parameter of the WELLDATA keyword) are taken into account
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Well Designer 21.4

VFPPROD points for Black Oil

It is now possible to edit the points of parameters of a black oil model in the VFP Correlation Plotting 

Points table, which are used in calculation of VFP curves based on the compositional model
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Well Designer 21.4

Modeling the corrosion of well material

The corrosion of well material may now be modeled using the deWaard (1995) model with the help of the 

WELCORER keyword
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Well Designer 21.4

Well Profile tab

It is now possible to show several parameters (pressure, temperature, etc.) simultaneously for different 

combinations of rates, tubing head pressures (THP), GFR, WFR, ALQ and correlation types
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Licensing and License Server
License server 21.4
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License server 21.4

Licensing and License Server

License use statistics aggregated by users, groups, queues, and license types may be 

visualized in the tNavigator graphical interface.

A summary table on the use of licenses has been added to the calculation log.
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Documentation & Localization
Documentation 21.4
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A section with the list of supported keywords in IN format is available as a part of User Manual.

Documentation 21.4

Built-in documentation
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A tutorial for Geology Designer:

GD4.7. How To Work With SEGY Headers

This tutorial provides a workflow for import of seismic 3D data in the case 

where

the text header contains no information concerning the inlines and crosslines 

positions in the SEG-Y file.

A tutorial for Geology Designer and Model Designer:

COMMON1.9. How To Create Dual Porosity Models via DFN

This tutorial covers the basic workflow for creating discrete fracture network

(DFN) and dual porosity (DP) models in Geology Designer and Model Designer.

The input data are loaded, the geological and (later) dynamic models are 

built, then the calculations are run and the results are analyzed.

Documentation 21.4

New training tutorials (1)
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A tutorial for Model Designer:

MD3.3. How To Create Geothermal Model

This tutorial explores the creation of a geothermal black oil model with temperature

extension using a simple grid with a five-point well placement system as an

example. The tutorial also includes the .data file of the resulting geothermal model.

A tutorial for Model Designer and AHM:

MDAHM1.5. How To Use Ensemble Smoother Method

In this tutorial, we show the approach to running the ensemble smoothing method. 

The initial data are loaded into Model Designer, the necessary variables and

workflow are created, an initial ensemble of variants is generated, and the ensemble 

smoothing method with the defined objective function is started.

Documentation 21.4

New training tutorials (2)
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A tutorial for Simulator:

SIM6.10. How To Model Single Well Chemical Tracer Test 

This tutorial explores a compositional model with chemical 

reactions. The ester is modeled as two components, one in 

the oil phase and the other in the water phase. The 

distribution of ether between phases is modeled using 

chemical reactions. The ester dissolved in water reacts with 

water to form ethanol and acetic acid.

Documentation 21.4

New training tutorials (3)
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Thank you for your attention!
The complete list of new features is available in the Release Notes
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